Search found 151 matches

by bglod
Thu Sep 20, 2018 5:23 am
Forum: Troubleshooting
Topic: Bladerf x40 - version_check is missing FPGA version compat table entry?
Replies: 4
Views: 45

Re: Bladerf x40 - version_check is missing FPGA version compat table entry?

Only the one power LED (D1) should illuminate. Do you have FPGA autoloading enabled? That could be messing things up. There are two types: host-side autoloading, and SPI flash autoloading. To disable host-side autoloading, rename the "hostedx115.rbf" "hostedx40.rbf" to something else. This file is l...
by bglod
Wed Sep 19, 2018 8:16 am
Forum: Troubleshooting
Topic: Bladerf x40 - version_check is missing FPGA version compat table entry?
Replies: 4
Views: 45

Re: Bladerf x40 - version_check is missing FPGA version compat table entry?

I've seen this before, but I forget the fix.
  1. Download/install latest Windows installer
  2. Update FX3 firmware to latest
    1. The Windows installer might be able to do this for you, but ..
    2. If you have trouble, try the recovery method.
by bglod
Tue Sep 18, 2018 12:18 pm
Forum: Troubleshooting
Topic: bladeRF x40 appears dead
Replies: 10
Views: 924

Re: bladeRF x40 appears dead

I just added this section in our Troubleshooting Page on our Wiki. Let me know if anything is unclear.
by bglod
Tue Sep 18, 2018 8:43 am
Forum: Troubleshooting
Topic: Caliberation/AGC Issue Help
Replies: 4
Views: 69

Re: Caliberation/AGC Issue Help

No, that is okay. This appears to be a bug as we are able to reproduce it on our end. Feel free to track the progress on the issue tracker.
by bglod
Mon Sep 17, 2018 11:00 am
Forum: Troubleshooting
Topic: MATLAB & Windows Problems After Upgrading to Latest release (Aug 2018)
Replies: 4
Views: 330

Re: MATLAB & Windows Problems After Upgrading to Latest release (Aug 2018)

If you figure it out, please feel free to send us a pull request!
by bglod
Mon Sep 17, 2018 10:54 am
Forum: Troubleshooting
Topic: Caliberation/AGC Issue Help
Replies: 4
Views: 69

Re: Caliberation/AGC Issue Help

Can you try running the "cal table agc rx" command in the CLI with verbose output?

Code: Select all

bladeRF-cli -v verbose -e "cal table agc rx"
by bglod
Mon Sep 17, 2018 10:51 am
Forum: Troubleshooting
Topic: bladeRF-cli can't connect first time
Replies: 13
Views: 250

Re: bladeRF-cli can't connect first time

greetings am trying to specify a frequency range i want to use and i am failing to do so am new to this am using bladeRF-cli. any ideas. thank you While I'm glad OP was able to help you out, please create a new thread if you have an unrelated question. This helps keep topics on track and doesn't st...
by bglod
Fri Sep 14, 2018 12:14 pm
Forum: Troubleshooting
Topic: bladeRF-cli can't connect first time
Replies: 13
Views: 250

Re: bladeRF-cli can't connect first time

To my knowledge, the samples are not stored with associated timestamps. It's possible to do, but you'd have to modify the HDL and some parts of libbladeRF/bladeRF-cli to handle it. If the timestamps don't need to be exactly matched up with the samples, you could periodically read the current timesta...
by bglod
Thu Sep 13, 2018 11:02 am
Forum: Troubleshooting
Topic: BladeRF xA9 load FPGA problem.
Replies: 2
Views: 85

Re: BladeRF xA9 load FPGA problem.

Please do not use that branch directly as it is right now -- it is extremely broken and may cause harm!! (I should probably remove it, tbh...) If you need this functionality "now" just use master and modify this line: https://github.com/Nuand/bladeRF/blob/601d8fe9e6e65b7649bc52385c0e02237ce67961/hos...
by bglod
Mon Sep 10, 2018 1:31 pm
Forum: Troubleshooting
Topic: BladeRF 2.0 A9 - Not responding to open after recover
Replies: 4
Views: 159

Re: BladeRF 2.0 A9 - Not responding to open after recover

Haha, those darn misbehaving USB 3 ports...

Actually, if you want, take a look at our list of good/bad USB controllers if you don't see your motherboard listed, feel free to fill in the necessary information in the "known problematic configurations" list!