BladeRF for ADS-B receive frequency setting.

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
Posts: 1
Joined: Tue Jan 17, 2017 2:10 am

BladeRF for ADS-B receive frequency setting.

Post by prafullasarode » Thu Feb 02, 2017 10:49 pm

I am new to bladeRF and not very sure in which forum to post this question.

I am new to RF and a software person, so please excuse if the questions are silly.

I recently purchased my bladeRF board and try to capture ADS-B data, but the performance is not as expected. Initial results shows RTL-SDR usb-dongle giving better performance compared to bladeRF.
My question is, in the bladeRF_adsb.c file the receive frequency is set to 1086MHz, even though ADS-B center frequency is 1090MHz. If I try to set the center frequency around 1090MHz the results are very poor

1. What shall be the center frequency setting to achieve best results?

Following is the default setting of RX module
struct module_config rx_config =
.frequency = 1086000000,
.bandwidth = 14000000,
.samplerate = 16000000,
.vga1 = 10,
.vga2 = 6

With this setting the performance is very poor, but if I change xn_lna = BLADERF_LNA_GAIN_MID, .vga1 = 28, .vga2 = 18 the results improves, but still poor compared to RTL-SDR.

I also have XB300 board, if I use it with bladeRF board the results are even poorer, if I enable it.

2. To improve the results to professional grade ADS-B receiver what settings shall be done.


Posts: 11
Joined: Mon Apr 11, 2016 12:41 pm

Re: BladeRF for ADS-B receive frequency setting.

Post by ifrasch » Thu Feb 16, 2017 10:10 pm

Hi prafullasarode,

1) For the bladeRF ADS-B implementation you need to leave the center frequency at 1086 MHz. The bladeRF ADS-B decoder has a -Fs/4 digital mixer in the FPGA which shifts the received baseband IQ signal down in frequency by 4MHz. That means that after the mixer, the center frequency of the IQ signal is at 1090 MHz, the ADS-B frequency.

2) I have not personally used the ADS-B decoder before, but I would continue messing around with the gains until you get something good. Try increasing VGA1 first, then VGA2. I'm surprised that the XB300 is giving you worse results. Are you sure you have it enabled?

Post Reply