BladeRF 2.0 and gqrx

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
jarek556
Posts: 3
Joined: Mon Oct 15, 2018 9:52 pm

BladeRF 2.0 and gqrx

Post by jarek556 » Wed Oct 17, 2018 3:15 pm

I can't run gqrx with BladeRF 2.0. It works nice with old BldeRF, but with new nothing happens when I'm pressing "Start" button.
I've tried with gqrx 6.3.0 from debian stretch and with latest gqrx build from sources.
BladeRF 2.0 works ok with other apps.

bglod
Posts: 179
Joined: Thu Jun 18, 2015 6:10 pm

Re: BladeRF 2.0 and gqrx

Post by bglod » Tue Oct 30, 2018 11:49 am

Your version of gr-osmosdr may be outdated. Your best bet is to build from source either using PyBOMBS (easiest) or manually. Have you checked out our Getting Started: Linux Wiki page?

Before building from source, I recommend removing all bladeRF, gqrx, gnuradio, etc. packages from your system via your package manager (to avoid any potential conflicts).
Electrical Engineer
Nuand, LLC.

Post Reply