Cannot see waterfall

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
blartin
Posts: 7
Joined: Mon Jul 16, 2018 4:52 pm

Cannot see waterfall

Post by blartin » Tue Aug 07, 2018 2:03 pm

Hi all,
I recently bought an Bladerf x40 with GPIO expansion board, and started to see what can I do with it.

On the other hand I have a Hackrf One and when plugged to my usb 3 port, can display a waterfall and start working.

But when I plug the bladerf, nothing happens even though it is recongized by gqrx in the device selection window.

What may I doing wrong?

Thanks in advance!

bglod
Posts: 179
Joined: Thu Jun 18, 2015 6:10 pm

Re: Cannot see waterfall

Post by bglod » Tue Aug 14, 2018 5:53 pm

Is the FPGA loaded? Does gqrx print any errors? Does it show up in dmesg? Can you give us a version printout using the bladeRF-cli -e "version" ?
Electrical Engineer
Nuand, LLC.

blartin
Posts: 7
Joined: Mon Jul 16, 2018 4:52 pm

Re: Cannot see waterfall

Post by blartin » Wed Aug 15, 2018 9:13 am

Thank you, the FPGA is loaded, and here is the output of the commands you suggested:

bladerf

Code: Select all

sdr@sdrtin:~$ bladeRF-cli -i
bladeRF> version

  bladeRF-cli version:        1.5.0-0.2016.06-2
  libbladeRF version:         1.8.0-0.2016.06-2

  Firmware version:           1.9.1
  FPGA version:               0.6.0

bladeRF> info

  Serial #:                 6a5c77f482ba7d610f008ce1868aaeb9
  VCTCXO DAC calibration:   0x8d59
  FPGA size:                40 KLE
  FPGA loaded:              yes
  USB bus:                  2
  USB address:              21
  USB speed:                Hi-Speed
  Backend:                  libusb
  Instance:                 0
gqrx

Code: Select all

sdr@sdrtin:~$ gqrx 
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

qt5ct: using qt5ct plugin
Controlport disabled
No user supplied config file. Using "default.conf"
qt5ct: D-Bus global menu: no
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.11
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp 
FM demod gain: 3.05577
Resampling audio 96000 -> 48000
IQ DCR alpha: 1.04166e-05
Using audio backend: auto
BookmarksFile is /home/sdr/.config/gqrx/bookmarks.csv
getDeviceList : Available input devices:
    0 : "nuand bladeRF SN 6a5c...aeb9"
    1 : "RFSPACE SDR-IQ Receiver"
    2 : "RFSPACE SDR-IP Receiver"
    3 : "RFSPACE NetSDR Receiver"
    4 : "RFSPACE Cloud-IQ Receiver"
    5 : "RTL-SDR Spectrum Server"
    6 : "Red Pitaya Transceiver Server"
    7 : "Complex Sampled (IQ) File"
Loading configuration from: "default.conf"
Configuration file: "/home/sdr/.config/gqrx/default.conf"
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.11
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp 
Opening nuand bladeRF with device identifier string: "*:instance=0"
 Serial # 6a5c...aeb9
 FW v1.9.1 FPGA v0.6.0
IQ DCR samp_rate: 160000
IQ DCR alpha: 6.24996e-06
Changing NB_RX quad rate: 96000 -> 160000
New antenna selected: "RX"
********************
Gain name: "LNA"
      min: 0
      max: 6
     step: 3
Gain name: "VGA1"
      min: 5
      max: 30
     step: 1
Gain name: "VGA2"
      min: 0
      max: 30
     step: 3
********************
No change in output device:
  old: 
  new: 
IQ DCR samp_rate: 160000
IQ DCR alpha: 6.24996e-06
Requested sample rate: 160000
Actual sample rate   : "160000.000000"
New FFT rate: 25 Hz
[INFO @ bladerf.c:791] Clamping bandwidth to 1500000Hz
Requested bandwidth: 0 Hz
Actual bandwidth   : 1.5e+06 Hz
setFreqCorr : 0 ppm
New LNB LO: 0 Hz
Failed to set out of bound frequency: 1e+12
Failed to set out of bound frequency: 1.445e+08
New mode index: 5
FM demod gain: 0.509296
Filter preset for mode 5 LO: -80000 HI: 80000
Generating taps for new filter   LO:-80000   HI:80000 TW:32000   Taps: 19
setFftRate to "50 fps"
New FFT rate: 50 Hz
New FFT rate: 50 Hz
New FFT rate: 50 Hz
New FFT rate: 50 Hz
setFftSize to "65536"
Changing baseband FFT size to 65536
New FFT rate: 50 Hz
New FFT rate: 50 Hz
Generating taps for new filter   LO:-114000   HI:114000 TW:48000   Taps: 13
dmesg

Code: Select all

sdr@sdrtin:~$ dmesg | grep blade
[ 3765.955320] usb 2-2: Product: bladeRF
[ 4892.680983] usb 2-2: Product: bladeRF

Thank you again,

bglod
Posts: 179
Joined: Thu Jun 18, 2015 6:10 pm

Re: Cannot see waterfall

Post by bglod » Thu Aug 16, 2018 1:48 pm

Couple things I noticed. First is you're on a USB 2 port, so your sample rate needs to be limited to less than about 8 MSPS. The second is, double check the settings in the gqrx device configuration window, it looks like there might be some issues there. Disable decimation, set the sample rate to 5 MSPS and bandwidth to 3 MHz or so. Then click the "play" button in gqrx and you should see a waterfall. If you still don't see anything, please attach a screen shot of the gqrx device configuration.

What are the 3 LEDs on the board doing while the gqrx waterfall is supposedly running?
Electrical Engineer
Nuand, LLC.

blartin
Posts: 7
Joined: Mon Jul 16, 2018 4:52 pm

Re: Cannot see waterfall

Post by blartin » Fri Aug 17, 2018 7:12 am

Thank you, I was blind. It was indeed a configuration issue. My bad!

I connected the board to a USB 3 port and set up gqrx as you suggested.

Now I can start working with bladeRF and compiling Nuand branches of gqrx and gr-osmosdr. I'm happy and very thankful!

bglod
Posts: 179
Joined: Thu Jun 18, 2015 6:10 pm

Re: Cannot see waterfall

Post by bglod » Tue Aug 21, 2018 11:05 am

Fantastic! Thanks for following up.
Electrical Engineer
Nuand, LLC.

Post Reply