issue regarding to the bladeRF intallation

Off topic threads and discussions

Moderator: robert.ghilduta

Post Reply
Nandu
Posts: 4
Joined: Sat Oct 07, 2017 2:21 am

issue regarding to the bladeRF intallation

Post by Nandu » Sat Oct 07, 2017 3:31 am

i am nandu working in tenet technetronic as an embedded engineer. Since am working in bladerf device in ubuntu 14.04 by following prescribed manual and wiki page given in Nuand/bladeRF wiki page during the installation process, there i had a problem while checking basic device operation.
By running the command "bladeRF-cli -i"
The error is:Failed to open device (first available): Insufficient permissions for the requested operation.

And also i tried the command "sudo bladeRF-cli -i"
The error is: Failed to open device (first available): Operation timed out.

Please find the below attached documents regarding to the problem i have faced and Please rectify the above issue.
img1.png
Thanks & Regards
Nandu
Embedded Engineer
Tenet Technetronics
No. 2514/U, 7th A Main Road,
Opp. B.B.M.P Swimming pool, Hampinagar
RPC Layout, Vijayanagar, Banglore,Karnatka 56014.
--

bglod
Posts: 56
Joined: Thu Jun 18, 2015 6:10 pm

Re: issue regarding to the bladeRF intallation

Post by bglod » Sun Oct 08, 2017 2:10 pm

What happens if you run with the "-v verbose" option?

Do you see any anomalies in dmesg when you plug in the bladeRF?

Nandu
Posts: 4
Joined: Sat Oct 07, 2017 2:21 am

Re: issue regarding to the bladeRF intallation

Post by Nandu » Sun Oct 08, 2017 11:12 pm

hi, thanks for the reply,
i tried "-v verbose" it shows an error "-v: command not found" (img1).

Also i tried in other option that "bladeRF-cli -v verbose" than also it shows the same error
"Failed to open device (first available): Insufficient permissions for the requested operation" (img2).


Thanks & Regards
Nandu
Embedded Engineer
Tenet Technetronics
No. 2514/U, 7th A Main Road,
Opp. B.B.M.P Swimming pool, Hampinagar
RPC Layout, Vijayanagar, Banglore,Karnatka 56014.
Attachments
img1.png
img2.png

Nandu
Posts: 4
Joined: Sat Oct 07, 2017 2:21 am

Re: issue regarding to the bladeRF intallation

Post by Nandu » Sun Oct 08, 2017 11:18 pm

and i tried "bladeRF-cli -i -v verbose" this also shows the same error
"Failed to open device (first available): Insufficient permissions for the requested operation
"
Attachments
img3.png

bglod
Posts: 56
Joined: Thu Jun 18, 2015 6:10 pm

Re: issue regarding to the bladeRF intallation

Post by bglod » Mon Oct 09, 2017 7:33 am

Apologies if it wasn't clear. The "-v verbose" is an option to bladeRF-cli, so run either:

Code: Select all

bladeRF-cli -i -v verbose
or, if you haven't given your user the appropriate permissions:

Code: Select all

sudo bladeRF-cli -i -v verbose
We recommend that you give your user permission to access the bladeRF device. You can do this by adding your user to the appropriate group. The group is specified when you build libbladeRF. The default group is "plugdev". More details here.

bglod
Posts: 56
Joined: Thu Jun 18, 2015 6:10 pm

Re: issue regarding to the bladeRF intallation

Post by bglod » Mon Oct 09, 2017 7:34 am

Also note the permissions of the hosted*.rbf file ... you'll want to make sure your user has read access to that file.

Nandu
Posts: 4
Joined: Sat Oct 07, 2017 2:21 am

Re: issue regarding to the bladeRF intallation

Post by Nandu » Thu Oct 12, 2017 11:21 pm

hi,
i tried "sudo bladeRF-cli -i -v verbose" but am getting the same error
[ERROR @ file_ops.c:119] file_read_buffer: could not open /usr/share/Nuand/bladeRF/hostedx115.rbf: Permission denied
Failed to open device (first available): Insufficient permissions for the requested operation
what shall i do next??

bglod
Posts: 56
Joined: Thu Jun 18, 2015 6:10 pm

Re: issue regarding to the bladeRF intallation

Post by bglod » Fri Oct 13, 2017 9:13 am

Nandu wrote:
Thu Oct 12, 2017 11:21 pm
[ERROR @ file_ops.c:119] file_read_buffer: could not open /usr/share/Nuand/bladeRF/hostedx115.rbf: Permission denied
Failed to open device (first available): Insufficient permissions for the requested operation
It's telling you the problem in that error message. There's a permissions error of some kind (though I'd have expected sudo to have gotten around that).
  • What does the command "ls -lha /usr/share/Nuand/bladeRF" show?
  • What does the command "groups" show?
  • Have you tried logging out and logging back in or restarting to make any group changes effective?
  • What if you download the latest hostedx115.rbf from our website and try to use that? (run "bladeRF-cli -l /path/to/hostedx115.rbf -i -v verbose")

Post Reply