DC offset table generation failed

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
hykang
Posts: 1
Joined: Tue Nov 19, 2019 6:36 pm

DC offset table generation failed

Post by hykang » Tue Nov 19, 2019 6:54 pm

I'm trying to generate DC offset table for bladeRF A40.

All sub-command in bladeRF-cli program is OK.

But sub-command for generation DC offset table is failed:

===========================================
hykang@xenial-Z170:~$ bladeRF-cli -i
bladeRF> cal lms

LPF tuning module: 23

TX LPF I filter: 37
TX LPF Q filter: 29

RX LPF I filter: 30
RX LPF Q filter: 30

RX VGA2 DC reference module: 25
RX VGA2 stage 1, I channel: 39
RX VGA2 stage 1, Q channel: 35
RX VGA2 stage 2, I channel: 29
RX VGA2 stage 2, Q channel: 27

bladeRF> cal table dc rx
Calibrated @ 237500000 Hz: I= 480 (Error: 0.84), Q= 416 (Error: 0.05) DC-LUT: Max (I=-70, Q=-68) Mid (I= -1, Q= Calibrated @ 247500000 Hz: I= 480 (Error: 0.88), Q= 416 (Error: 0.16) DC-LUT: Max (I=-68, Q=-67) Mid (I= 0, Q= Calibrated @ 257500000 Hz: I= 512 (Error: 1.21), Q= 416 (Error: 0.41) DC-LUT: Max (I=-88, Q=-68) Mid (I= -5, Q= Calibrated @ 267500000 Hz: I= 512 (Error: 1.07), Q= 416 (Error: 0.05) DC-LUT: Max (I=-83, Q=-68) Mid (I= -3, Q= Calibrated @ 277500000 Hz: I= 512 (Error: 1.52), Q= 416 (Error: 0.07) DC-LUT: Max (I=-81, Q=-68) Mid (I= -3, Q= Calibrated @ 287500000 Hz: I= 512 (Error: 0.59), Q= 416 (Error: 0.82) DC-LUT: Max (I=-83, Q=-64) Mid (I= -4, Q= Calibrated @ 297500000 Hz: I= 512 (Error: 1.17), Q= 416 (Error: 0.19) DC-LUT: Max (I=-81, Q=-68) Mid (I= -3, Q= Calibrated @ 307500000 Hz: I= 512 (Error: 1.56), Q= 416 (Error: 0.43) DC-LUT: Max (I=-81, Q=-70) Mid (I= -3, Q= Calibrated @ 317500000 Hz: I= 512 (Error: 1.29), Q= 384 (Error: 1.00) DC-LUT: Max (I=-84, Q=-64) Mid (I= -3, Q= Calibrated @ 327500000 Hz: I= 480 (Error: 1.85), Q= 384 (Error: 0.20) DC-LUT: Max (I=-63, Q=-70) Mid (I= 1, Q= Calibrated @ 337500000 Hz: I= 480 (Error: 1.08), Q= 384 (Error: 0.93) DC-LUT: Max (I=-66, Q=-74) Mid (I= 0, Q= Calibrated @ 347500000 Hz: I= 480 (Error: 1.40), Q= 384 (Error: 0.28) DC-LUT: Max (I=-67, Q=-69) Mid (I= 1, Q= Calibrated @ 357500000 Hz: I= 480 (Error: 0.75), Q= 384 (Error: 0.70) DC-LUT: Max (I=-70, Q=-73) Mid (I= 0, Q= Calibrated @ 367500000 Hz: I= 480 (Error: 0.12), Q= 384 (Error: 1.28) DC-LUT: Max (I=-73, Q=-75) Mid (I= 0, Q= 2) Min (I= 25, Q= 26)

Error: File or device I/O failure

bladeRF>
========================================================


Thanks in advance.

robert.ghilduta
Posts: 72
Joined: Thu Feb 28, 2013 11:14 pm

Re: DC offset table generation failed

Post by robert.ghilduta » Fri Dec 20, 2019 3:28 pm

What USB interface (2 or 3) are you running the bladeRF with? USB 3.0 would be strongly suggested.
Are you building from source or did you apt-get install the bladeRF package?
Lastly, does dmesg show any USB messages related to the bladeRF?

Post Reply