bladeRF 2.0 xA4 invalid fpga size

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
helpmeplease
Posts: 1
Joined: Tue Feb 22, 2022 7:55 pm

bladeRF 2.0 xA4 invalid fpga size

Post by helpmeplease »

I am having issues running the BladeRF2.0 xA4 FPGA on a RPI4 Dragonfocal bladeRF seems to respond the best on this device rather then others . I have tried J6 pin for recovery "help recover" still no fix I have also tried to fix problem in windows 10 command promp desktop an dragonfocal os on linux labtop have had no luck with it . I have two devices i purchased . The other one works great right out the box the second one has been very problematic right from first build on windows 10. some how wrong "fpga size 40" I need "FPGA size 49" SO i tried
flash_init_cal A4 0x1c71 in command promp bladeRF-cli -i and still no luck.........MY WIFE SAYS I SHOULD GO BACK TO COLLEGE.... L O L
PLEASE I NEED HELP


[email protected]:~$ bladeRF-cli -v verbose
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/libusb.c:642] Using libusb version: 1.0.23.11397
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/libusb.c:519] Found a bladeRF (idx=0)
[DEBUG @ host/libraries/libbladeRF/src/backend/usb/libusb.c:189] Bus 002 Device 002: Nuand bladeRF 2.0, serial ca03614488c144cb82e6618dcd09a30c
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/libusb.c:581] USB port reset succeeded for bladeRF ca03614488c144cb82e6618dcd09a30c
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/usb.c:106] Changing to USB alt setting 0
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf2/bladerf2.c:293] Read Firmware version: 2.4.0-git-a3d5c55f
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf2/bladerf2.c:299] Capability mask before FPGA load: 0x0000007f00000000
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:401] Found SPI flash manufacturer: WINBOND.
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:404] Found SPI flash device: W25Q32JV (32 Mbit).
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:452] SPI flash total size = 32 Mbit
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:453] SPI flash page size = 256 bytes
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:454] SPI flash erase block size = 65536 bytes
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:455] SPI flash number of pages = 16384
[VERBOSE @ host/libraries/libbladeRF/src/board/bladerf1/flash.c:456] SPI flash number of erase blocks = 64 pages
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/usb.c:106] Changing to USB alt setting 2
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/usb.c:106] Changing to USB alt setting 3
[ERROR @ host/libraries/libbladeRF/src/board/bladerf2/bladerf2.c:438] bladerf2_open: invalid FPGA size: 40
Failed to open device (first available): An unexpected error occurred
[email protected]:~$ bladeRF-cli -i
[ERROR @ host/libraries/libbladeRF/src/board/bladerf2/bladerf2.c:438] bladerf2_open: invalid FPGA size: 40
Failed to open device (first available): An unexpected error occurred
robert.ghilduta
Posts: 102
Joined: Thu Feb 28, 2013 11:14 pm

Re: bladeRF 2.0 xA4 invalid fpga size

Post by robert.ghilduta »

Ensure there is no RBF in the config, local directory, or the auto load directory, and go into bladeRF-cli -i and run "flash_init_cal A4 0x1c71".

If that doesn't work, you may want to set environmental variable BLADERF_FORCE_NO_FPGA_PRESENT to 1 by running "export BLADERF_FORCE_NO_FPGA_PRESENT=1" and rerunning the bladeRF-cli -i and flash_init_cal commands.
Post Reply