Page 1 of 1

BladeRF2.0 2Ch Rx corrupt data Rpi4

Posted: Mon Nov 22, 2021 7:22 am
by darkmess
I am having issues running the BladeRF2.0 in 2 channel mode (with GNUradio 3.9). I have built a basic flowgraph to replicate the issue. Currently running on a Raspberry Pi4, but had the same issue on a Corei7 Dell XPS.

Basic Flowgraph

When running a single channel, I get a nice clean and stable signal. When I run 2 channels I get weird corruption of the data as shown below. In the image below, you can see the noise pedestal of the input filter disappearing periodically. Any injected signal is also corrupted during this time.

I have tried using the gr-bladeRF block, but can not get this to build with GRC3.9. Not sure if this would fix the issue, but I could downgrade Gnuradio if anyone thinks its likely to help.

If anyone has and tips/tricks, or can replicate the issue I would be appreciative?

Re: BladeRF2.0 2Ch Rx corrupt data Rpi4

Posted: Tue Nov 23, 2021 9:08 am
by darkmess
Update - I have also tested this using the BladeRF-cli

This is working correctly for extended periods and does not suffer from any of the glitches experienced in GNUradio using Osmocom.

Re: BladeRF2.0 2Ch Rx corrupt data Rpi4

Posted: Fri Dec 03, 2021 7:57 am
by darkmess
Omsocom source - Does not work for 2x RX
gr-bladeRF - Does not work for 2xRx
bladeRF-cli stream to disk works correctly
SoapySDR - Works correctly(using custom block for 2 channel), but doesn't support biastee (or AGC as far as I can tell)

While I am still awaiting this thread being moderated, but I thought it best to post an update with the current status.

1. Got gr-bladeRF Gnuradio blocks compiled and installed with fresh build of GR3.9. Behavior is same as Osmocom (i.e. corrupt sample streams(probably dropped samples).
2. Updated libbladeRF to latest version.(no change)
3. Built Pothos SoapySDR and gr-SoapySDR
4. Soapy_BladeRF_Source only supports a single channel so had to use Soapy_Custom_Source to access 2 channels.

As far as I can tell the Soapy GNUradio blocks are working correctly and the corruption to the sample stream is now fixed. I get the occasional buffer underrun, but this is rare.

I am now unable to turn on the receive biastee with Soapy using the same arguments I used under osmocom and have been unable to find an alternative.

Re: BladeRF2.0 2Ch Rx corrupt data Rpi4

Posted: Mon Dec 20, 2021 12:43 am
by robert.ghilduta
Are you able to use the bladeRF config files to enable the biastees? Please see ... gfile.html