Failed to receive NIOS II response: Operation timed out

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
SamD
Posts: 6
Joined: Sun Nov 12, 2017 10:55 pm

Failed to receive NIOS II response: Operation timed out

Post by SamD » Thu Nov 23, 2017 2:40 am

Hi,

I first installed the BladeRF on a Win10 x64, using the bladeRF-win-installer-2016.05-rc2-alpha2 installer that's known to work on Win10.

It worked at once and I was able to use bladeRF-cli.

But then I would get
bladeRF-cli -i -v verbose
[VERBOSE @ libusb.c:541] Using libusb version: 1.0.19.10905
[VERBOSE @ libusb.c:422] Found a bladeRF (idx=7)
[VERBOSE @ capabilities.c:45] Capability mask before FPGA load: 0x0000000700000000
[VERBOSE @ usb.c:112] Changing to USB alt setting 0
[VERBOSE @ usb.c:112] Changing to USB alt setting 1
[DEBUG @ nios_legacy_access.c:123] Failed to receive NIOS II response: Operation timed out
[DEBUG @ nios_legacy_access.c:213] Failed to read FPGA version[0]: Operation timed out
Failed to open device (first available): Operation timed out
I don't know if it could be linked to the fact that I would also try to use the BladeRF in an Ubuntu virtual machine.

I would have to reinstall the driver using Zadig, unplug, replug, restart the PC, and maybe after some time I would be able to access the BladeRF again.

Any idea what could be the problem?

Thanks.

bglod
Posts: 67
Joined: Thu Jun 18, 2015 6:10 pm

Re: Failed to receive NIOS II response: Operation timed out

Post by bglod » Fri Dec 01, 2017 1:33 pm

It's probably related to the USB pass through to the VM guest OS and then trying to access the bladeRF from the host OS.
Electrical Engineer
Nuand, LLC.

Post Reply