unable to get BladeRF A4 to work

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
L07tB0y
Posts: 1
Joined: Fri Aug 17, 2018 10:11 am

unable to get BladeRF A4 to work

Post by L07tB0y » Fri Aug 17, 2018 10:18 am

I have tried a MacBook pro with High Sierra 10.13.6 and macports.

Tried a windows VM with the latest windows client from nuand website.

Tried Kali Linux with apt-get and gnuradio

the thing that is not working for me on Mac and Liux is osmodr it will not compile or install etc and I have tried everything I can in my limited Linux knowledge. I believe this is the link that acts as a driver for the A4 board to get it to work with gnuradio?

Ideally I would like to get it to work on a Mac but I would be open to getting it working on any OS at this point.

I have called and left voicemail to Nuand support as well if I do find something that works I will write up the process that worked for me and post here.

bglod
Posts: 180
Joined: Thu Jun 18, 2015 6:10 pm

Re: unable to get BladeRF A4 to work

Post by bglod » Tue Aug 21, 2018 11:00 am

OSX is experiencing some GNU Radio issues at the moment; we are working on this. Windows and Linux are currently working. I recommend Linux from a general debuggability perspective though.

We introduced several changes to gr-osmosdr recently and your Linux distribution's package manager may not have the latest and greatest version. You'll need to build gr-osmosdr, gqrx, and GNU Radio from source. PyBOMBS is a "package manager" or "build system" for GNU Radio that you may want to look into to make this process significantly easier. We have a short PyBOMBS guide on our Wiki.
Electrical Engineer
Nuand, LLC.

Post Reply