Can't run calibrate lms

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
dm20133
Posts: 1
Joined: Mon Oct 22, 2018 3:49 pm

Can't run calibrate lms

Post by dm20133 » Mon Oct 22, 2018 3:53 pm

When I run calibrate lms from either the interactive command line or from a script it errors with:
Error: Command requires FPGA to be loaded.

I know the FPGA is loaded because when I run version on the bladeRF-cli it shows FPGA version: 0.8.0

I did the autoloading FPGA software by using the -L command and loaded the xxxA4-latest.rbf

Any help would be appreciated.

bglod
Posts: 179
Joined: Thu Jun 18, 2015 6:10 pm

Re: Can't run calibrate lms

Post by bglod » Tue Oct 30, 2018 11:32 am

The bladeRF-cli -L option writes the FPGA image to SPI flash. This operation (if I remember correctly?) interrupts the operation of the FPGA and could be what's causing your issue, especially if you didn't do a power cycle after running the -L command.

Now, having said that, I do not recommend using the -L command unless you are operating the bladeRF without a host machine (i.e. 'headless'). The flash operation takes a long time, not only to write the data to flash, but also to read it out during FPGA configuration after power-up. It's significantly faster to use host-based auto loading. Host-based auto loading also makes it easier to keep the FPGA up-to-date as new versions are released. If you decide to use host-based auto loading, remember to clear the SPI flash image using the command: "bladeRF-cli -L X" otherwise you may run into race conditions or other issues.

If you're certain you want the FPGA image stored in SPI flash, then only issue the command once to write the image to flash. Then power cycle the board and wait until all four LEDs turn on before opening the bladeRF with "bladeRF-cli -i". I also recommend upgrading the FX3 firmware to v2.3.1 if you haven't already. This version fixes an issue that interrupted FPGA configuration if the host opens the bladeRF before the FPGA is fully configured.

If you're still experiencing issues, please run the CLI in verbose mode so we can get a better understanding of where it's failing in the code. To do this add "-v verbose" to bladeRF-cli.
Electrical Engineer
Nuand, LLC.

Post Reply