Issues setting TX Gains in GRC

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
OskarM
Posts: 19
Joined: Sun Dec 09, 2018 3:02 pm

Issues setting TX Gains in GRC

Post by OskarM » Sun Dec 09, 2018 3:44 pm

Hi,

I have the bladeRF x40 board and I have issues setting TX Gains using osmocom sink in gnuradio-companion. I have a rtl-sdr as a "signal analyzer" to monitor the output (and some 20db attenuators just in case).

In the sink block there are the RF / IF / BB Gains that supposed to be matched to (according to GrOsmoSDR wiki):
Sink:
BB Gain: TX VGA1 [-35, -4]
IF Gain: N/A
RF Gain: TX VGA2 [0, 25]
Setting "sink -> RF Gain" does nothing - no change of the output (no matter what value I input)
Setting "sink -> IF Gain" does nothing - no change of the output
Setting "sink -> BB Gain" works from value of 16 to roughly 72 (I can see aplitude change of the signal)

Setting BB gain below 16 throws [INFO @ fpga_common/src/lms.c:1015] Clamping TXVGA2 gain to 0dB


I was trying to see into the libbladerf and lms code looking for the gain values and it seems to correlate to above values. The bladeRF-cli works OK, so it is something on the grc->osmocom->libbladerf conenction I guess, but I am quite new to the GRC internals and couldnt find the reason for that.

Any ideas?
thanks
Oscar

robert.ghilduta
Posts: 72
Joined: Thu Feb 28, 2013 11:14 pm

Re: Issues setting TX Gains in GRC

Post by robert.ghilduta » Wed Dec 19, 2018 12:03 am

Sorry about the delayed response. This is a "feature" of us having unified gains for the bladeRFs in libbladeRF. The gains are now unified under "BB". Our goal has been to make the gr-osmosdr parameters to be portable among our devices.

dionisiocar
Posts: 4
Joined: Fri Aug 30, 2019 5:09 am
Location: São Paulo - Brazil

Re: Issues setting TX Gains in GRC

Post by dionisiocar » Mon Apr 20, 2020 2:46 pm

Hi,
I am facing a related issue.
I am using the:
Nuand bladeRF 2.0 Serial # 4ced...6a7d FW v2.3.2 FPGA v0.11.0
gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.13.5

I see the noise floor changing when I change the RF Gain. However, I do understand why the peak (FFT) is always around -14 dB.

I am running a sine loopback.


Cheers

Post Reply