Continuous Operation of xA9 Board

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
DocJava
Posts: 4
Joined: Wed Feb 22, 2017 5:52 am

Continuous Operation of xA9 Board

Post by DocJava » Sun Jan 20, 2019 3:24 am

Has anyone else encountered a crash of the PyBOMB installed version of gqrx with a single bladeRF xA9 board connected overnight? Both the USB3 and DC power jacks are connected to the device and everything works perfectly, tuned to 107.7 MHz, until sometime in the middle of the night when the device stops functioning. I'm not sure if this is an issue with gqrx or with the xA9, but thought it would be worth asking on the forum about this.

The ideal case is that the xA9/gqrx should function 24/7 without any issues. I'd like to resolve this issue before purchasing any additional radios.

Respectfully,
DocJava

DocJava
Posts: 4
Joined: Wed Feb 22, 2017 5:52 am

Re: Continuous Operation of xA9 Board

Post by DocJava » Tue Jan 22, 2019 12:48 am

I'm receiving these errors just before gqrx crashes. This is after about 24 hours of continuous operation.

Code: Select all

[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/backend/usb/libusb.c:1211] Failed to submit transfer in submit_transfer: LIBUSB_ERROR_NO_DEVICE
[ERROR @ host/libraries/libbladeRF/src/streaming/sync.c:306] wait_for_buffer: Timed out waiting for buf_ready after 3000 ms
[bladeRF source] work: bladerf_sync_rx error: Operation timed out
[ERROR @ host/libraries/libbladeRF/src/streaming/sync.c:306] wait_for_buffer: Timed out waiting for buf_ready after 3000 ms
[bladeRF source] work: bladerf_sync_rx error: Operation timed out
[bladeRF source] work: Consecutive error limit hit. Shutting down.
[bladeRF source] stop: DEBUG: stopping source
[ERROR @ host/libraries/libbladeRF/src/backend/usb/nios_access.c:69] Failed to send NIOS II request: No devices available
[ERROR @ host/libraries/libbladeRF/src/board/bladerf2/rfic_fpga.c:281] _rfic_fpga_enable_module: dev->backend->rffe_control_read(dev, &reg) failed: No devices available
terminate called after throwing an instance of 'std::runtime_error'
  what():  stop: bladerf_enable_module failed: No devices available (-7)
Respectfully,
DocJava

bglod
Posts: 201
Joined: Thu Jun 18, 2015 6:10 pm

Re: Continuous Operation of xA9 Board

Post by bglod » Tue Jan 22, 2019 3:27 pm

Those errors look like the device disconnected from USB momentarily. Usually, this is a USB cable and/or controller issue. Have you tried another machine and/or USB controller? USB cable? You can also try to play with the sample rate to see if that has an impact. Other ideas include adjusting the number of transfers, number of buffers, and the buffer size.

General troubleshooting: https://github.com/Nuand/bladeRF/wiki/Troubleshooting
List of known good/problematic hosts / USB controllers: https://github.com/Nuand/bladeRF/wiki/T ... fic-issues

For what it's worth, we've run our production development boards continuously for many days on end without issue, so what you're trying to do should not be a problem.
Electrical Engineer
Nuand, LLC.

Post Reply