Enabling Gains and Amplifiers in GRC

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
KB_RF
Posts: 1
Joined: Tue Jun 18, 2019 2:35 pm

Enabling Gains and Amplifiers in GRC

Post by KB_RF » Tue Aug 27, 2019 8:07 pm

Hi,

I am currently working on a communications project utilizing two BladeRF 2.0 xA4 devices in a 2x2 mimo configuration. Unfortunately I can't seem to get very far into the project.


I am currently testing gains with the simple loopback example that was provided (I disabled the loopback feature and I seem to be receiving RF energy if I place the devices extremely close, otherwise I'm not seeing any signal).

I have been able to adjust the gain when I use the command line interface but I don't think adjusting the gains via the OSMOSDR source and sink blocks are working for me. I saw a couple of solutions in this forum but nothing that I have read seemed to solve my issue. Additionally, I can enable the BT-100 amplifiers via the command line interface but adding "biastee=tx" to the arguments list doesn't seem to enable anything (the blue lights do not turn on).

Any help would be greatly appreciated. Thanks.

robert.ghilduta
Posts: 61
Joined: Thu Feb 28, 2013 11:14 pm

Re: Enabling Gains and Amplifiers in GRC

Post by robert.ghilduta » Wed Aug 28, 2019 3:10 am

To enable the bladeRF 2.0 micro BT-100 amplifier in gr-osmosdr, try adding "bladerf=0," before "biastee=tx"
Also, please ensure hardware gain is set to manual if you intend to set gains manually. Have you tried using gqrx? Also, ensure you are using the latest sources, one way is to try these instructions: https://github.com/Nuand/bladeRF/wiki/G ... on_PyBOMBS

Post Reply