Linux pre-built binary help

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
Alex_Dan
Posts: 1
Joined: Mon Mar 02, 2020 11:48 am

Linux pre-built binary help

Post by Alex_Dan »

Dear Friends,

I am new to bladeRF and very excited that I have got my bladeRf micro 2.0 board and I successfully installed applications as suggested from the bladeRF wiki site on Mac and Windows with mostly OK by following instructions, but what I can't for the life of me do is to make all of the applications work as suggested on the "Getting Started: Linux" page :( And quite frustrated

Ideally I want to have bladerf micro 2.0 to wok on Raspberry PI 4 with GNU Radio, osmosdr and gqrx and I have tried almost every distro available from 32 bit to 64 bit Rsapian, Ubuntu, etc. non seem to work all the way (meaning with all off the applications above, I get the bladeRF-cli to work properly but then osmosdr or gnuradio can not find the device ) :( Then I tried to use Ubuntu 18.04 desktop and had bunch of problems building the solution there as well.

Anyways instead of detailing all the different issues/blockers I got with each environment by following wiki instructions or way of building PYBOMBS, from source, etc.

I have two questions that I would appreciate if someone can provide some insights;

1- Most every distro I have worked already have bladeRF under package library (apt-get install bladerf ) and I can install it without any error but when I try to run the bladeRF-cli with apt-get install pre-build binaries I get the device not found issue but when I compile the library it works so my question is why and if this approach does not work why is there a pre-build binary ?

2- I am ok to compile the bladeRF-cli library and make it work on most distros but because GNURadio is massive or that I have issues building, GR-OSMOSDR , can I use the pre-build binaries for the GNURadio , osmosdr and gqrx work with bladeRF since I can do apt-get install without any issues to all of these applications but looks like there is an important piece that is missing to make them work and I can not figure it out :( since it seems like osmocom can not find the device if I use the binaries.

Thanks a lot and sorry for the lengthy form post.

Looking forward for some help,
Cheers Alex
Post Reply