Windows Driver and USB Issues

Discussions related to embedded firmware, driver, and user mode application software development

Moderator: robert.ghilduta

pmmeasures
Posts: 9
Joined: Thu May 21, 2015 1:53 pm

Re: Windows Driver and USB Issues

Post by pmmeasures » Wed Dec 02, 2015 1:11 pm

I have never tried transmitting i only use SDR#

But I do have a ASUS Z97 motherboard also and i have issues on receive with Cypress (Bizzarly works set on 40Msps but drops at lower rates))

I am ok using the Lib drivers so to be sounds like your hitting a cypress issue.

jynik
Posts: 455
Joined: Thu Jun 06, 2013 8:15 pm

Re: Windows Driver and USB Issues

Post by jynik » Thu Dec 03, 2015 2:32 pm

Serge,

I'll spend some time looking into this to determine if the underlying issue is in our codebase or in the Cypress's driver. Unfortunately, if it's the latter, there's not much we can do other than run it up the flagpole to them.

In the meantime, it might be worth sticking with the libusb driver.

Best regards,
Jon

sergemalo
Posts: 14
Joined: Tue Nov 03, 2015 1:50 pm
Location: Montreal, Qc, Canada
Contact:

Re: Windows Driver and USB Issues

Post by sergemalo » Fri Dec 04, 2015 4:33 am

Hi Jon,

Thanks for your feedback. I really have no clue of what's the problem.
Let me know if you want me try something on my end, it's very quick to setup.
Also, I can recompile easily libbladerf under Windows now, if you want me to try a modification in a special branch.

Regards,
Serge
--------------------------------------------------------------------------------
Serge Malo
CDO & Co-founder, Skydel Solutions
www.skydelsolutions.com
Twitter: @skydelsol

Post Reply