Keep bias tee power on when using srsLTE

Discussions related to schematic capture, PCB layout, signal integrity, and RF development

Moderator: robert.ghilduta

Post Reply
fllay
Posts: 3
Joined: Sun Jan 13, 2019 5:49 am

Keep bias tee power on when using srsLTE

Post by fllay »

Is there a method to keep bias tee on? The bias can be turn on using CLI but when I use srsLTE (enb), it will reset everything from CLI setting. how can I keep the setting? Is there an option in config file that can turn bias power on just like in GNU Radio block? Otherwise, I have to do a lot of wiring to feed fours amplifier at the bladeRF port. Thank you
emmair
Posts: 1
Joined: Tue Mar 23, 2021 7:31 am

Re: Keep bias tee power on when using srsLTE

Post by emmair »

I am having the same problem with the bt-100 and bt-200 turning off/resetting upon startup of srsenb. A software solution would be helpful.
nerdasaur
Posts: 2
Joined: Sun Mar 07, 2021 10:44 am

Re: Keep bias tee power on when using srsLTE

Post by nerdasaur »

Have ya'll figured this problem out at all? i'm having significant issues w/ srsLTE. keep getting RX and TX failed warnings from ../rf_blade_imp.c
robert.ghilduta
Posts: 85
Joined: Thu Feb 28, 2013 11:14 pm

Re: Keep bias tee power on when using srsLTE

Post by robert.ghilduta »

You can use the bladeRF config file to control the biastees. Please take a look at https://nuand.com/bladeRF-doc/libbladeR ... gfile.html
For example putting the following in bladeRF.conf should default the bias tees to on:

Code: Select all

biastee_rx true
biastee_tx true
fllay
Posts: 3
Joined: Sun Jan 13, 2019 5:49 am

Re: Keep bias tee power on when using srsLTE

Post by fllay »

robert.ghilduta wrote: Tue May 25, 2021 1:22 am You can use the bladeRF config file to control the biastees. Please take a look at https://nuand.com/bladeRF-doc/libbladeR ... gfile.html
For example putting the following in bladeRF.conf should default the bias tees to on:

Code: Select all

biastee_rx true
biastee_tx true
It is working now. Thank you. Is there an option to set external ref. clock as well?

https://www.nuand.com/frequently-asked-questions/

Like this command.

bladeRF> set clock_sel external

Clock input: External via CLKIN
Post Reply