GNU Radio Companion Flow Graph for Blade?

Follow our development of DSP and SDR tutorials

Moderator: robert.ghilduta

2011EE10487
Posts: 18
Joined: Tue Feb 25, 2014 6:39 am

Re: GNU Radio Companion Flow Graph for Blade?

Post by 2011EE10487 » Sun Mar 16, 2014 10:48 pm

Hi,
I've pulled the latest from master and the error is removed now. But after all this it seems that I'm still getting the discontinuites as the output of spectrum analyser that I got is same as before.

bpadalino
Posts: 303
Joined: Mon Mar 04, 2013 4:53 pm

Re: GNU Radio Companion Flow Graph for Blade?

Post by bpadalino » Mon Mar 17, 2014 12:22 pm

Can you run the osmo FFT command with "--oscilloscope" at the end of it and show a movie or describe what the output looks like on the XY tab? This will give us time domain information. Looking at spectrum like that doesn't really give me a good understanding other than "Things are bad". Time domain will let me know if you are saturating (which is my guess) and by how much.

If you are saturating - lower your gains until you aren't. Things should appear much more sane at that point.

Brian

2011EE10487
Posts: 18
Joined: Tue Feb 25, 2014 6:39 am

Re: GNU Radio Companion Flow Graph for Blade?

Post by 2011EE10487 » Tue Mar 18, 2014 1:29 am

Hi Brian,
I've run the osmo FFT with oscilloscope. Here is the link to the video of the output https://drive.google.com/file/d/0B5ZnEv ... sp=sharing. I hope this gives you the required time domain information.

Thanks

bpadalino
Posts: 303
Joined: Mon Mar 04, 2013 4:53 pm

Re: GNU Radio Companion Flow Graph for Blade?

Post by bpadalino » Tue Mar 18, 2014 5:35 am

You should have been on the XY tab instead of the CH1 tab on the right hand side. That should show me the polar plot of what IQ looks like. From that view, it still looks pretty terrible, though. Something isn't right.

Do you have any input signal going into the device at all, or is it just open or terminated?

Brian

2011EE10487
Posts: 18
Joined: Tue Feb 25, 2014 6:39 am

Re: GNU Radio Companion Flow Graph for Blade?

Post by 2011EE10487 » Tue Mar 18, 2014 6:34 am

Here is the link to video with XY mode https://drive.google.com/file/d/0B5ZnEv ... sp=sharing.
I haven't got any input signal on the device. I've an antenna on the RX port of the device an trying to get the spectrum of signals present in the air with bladeRF. I got a good spectrum with USRP board and was hoping to get a similar from the bladeRF but something isn't right. Further can you tell me what should be the relationship between the sample rate and bandwidth. Shouldn't sample rate >= 2*bandwidth (Nyquist Criteria).

bpadalino
Posts: 303
Joined: Mon Mar 04, 2013 4:53 pm

Re: GNU Radio Companion Flow Graph for Blade?

Post by bpadalino » Tue Mar 18, 2014 6:59 pm

It looks like your I signal is just very erratic. Your Q signal seems fine tho. Also note that you should always turn off the Autorange option in those viewers. It's difficult to make sense of what you're actually seeing when it's jumping all around.

Your board may be malfunctioning but with no signal going in I am not sure what you're expecting to see other than just noise? Are you trying to transmit or receive?

The bandwidth is setting some internal low pass filters. The bandwidth should match to be around 1.25*(bandwidth of signal of interest) so the low pass corners don't encroach on your actual signal. Does that make sense?

Brian

yvesined
Posts: 5
Joined: Tue Mar 25, 2014 6:51 am
Location: Germany
Contact:

Re: GNU Radio Companion Flow Graph for Blade?

Post by yvesined » Fri Mar 28, 2014 3:13 am

wx5cw wrote:Here is the setup I have that currently works for the bladerf in gnuradio.
However make sure to load the setup.txt file for the inital configuration of the sytem via bladerf-cli then exit that and then load the gnuradio-companion and lauch the grc. Note: you might have to chmod 757 /dev/bladerf to get the grc to load and connect to the bladeRF. I will be posting a detailed walk though soon to help others get up and running with gnuradio.
bladeconfig.png
gnuradio-bladerf.png
Thank you! This worked fine for me!!! :geek: :D

poi
Posts: 4
Joined: Mon Mar 23, 2015 5:16 am

Re: GNU Radio Companion Flow Graph for Blade?

Post by poi » Thu Apr 09, 2015 4:40 am

2011EE10487 wrote:Here is the link to video with XY mode https://drive.google.com/file/d/0B5ZnEv ... sp=sharing.
I haven't got any input signal on the device. I've an antenna on the RX port of the device an trying to get the spectrum of signals present in the air with bladeRF. I got a good spectrum with USRP board and was hoping to get a similar from the bladeRF but something isn't right. Further can you tell me what should be the relationship between the sample rate and bandwidth. Shouldn't sample rate >= 2*bandwidth (Nyquist Criteria).
Hi 2011EE10487,

I'm trying to get spectrum of signals present in the air with bladeRF too. However, I don't have USRP board to compare the spectrum with bladeRF. The spectrum that I get is a noisy spectrum. I'm trying to remove noise with filtering but I couldn't obtain satisfying results.

BTW the aim is to obtain center frequency of a signal detected in the air. I'll determine the frequency then, it will be scanned in LTE-Cell-Scanner. I've tried to use peak detector to obtain, however it is useless as far as I can see.

Is your work still in progress?

Thanks

Post Reply