beginning with bladerf 2 (errors and lot of unsupported software)

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
Posts: 1
Joined: Sun Apr 05, 2020 10:30 am

beginning with bladerf 2 (errors and lot of unsupported software)

Post by YJesus »


Recently I have bought a Bladerf x4 micro, just for playing with GSM. At the time of purchase I only had a very good feedback from Blade, but for bladerf1.

Starting with Yate, I have follow this and when I try I got lot of:

2020-04-05_11:08:34.440778 <gsmtrx:MILD> Transmit underrun by 49 timeslots [0x7fbf4c01b8f0]
2020-04-05_11:08:34.440852 <gsmtrx:NOTE> ARFCN[0]: 1 burst(s) expired at 18456 2307/0 [0x7fbf4c00bb60]
skipped 1682
skipped 1275
2020-04-05_11:08:34.454636 <gsmtrx:MILD> Transmit underrun by 7 timeslots [0x7fbf4c01b8f0]
skipped 290
skipped 283
skipped 442
skipped 506
2020-04-05_11:08:34.481773 <gsmtrx:MILD> Transmit underrun by 33 timeslots [0x7fbf4c01b8f0]
2020-04-05_11:08:34.515820 <gsmtrx:MILD> Transmit underrun by 42 timeslots [0x7fbf4c01b8f0]
skipped 1629
skipped 986
skipped 696
2020-04-05_11:08:34.538260 <gsmtrx:MILD> Transmit underrun by 23 timeslots [0x7fbf4c01b8f0]
2020-04-05_11:08:34.538335 <gsmtrx:NOTE> ARFCN[0]: 1 burst(s) expired at 18625 2328/1 [0x7fbf4c00bb60]
skipped 1715
skipped 1002
skipped 830
skipped 517
2020-04-05_11:08:34.550088 <gsmtrx:MILD> Transmit underrun by 4 timeslots [0x7fbf4c01b8f0]
skipped 1191
skipped 1302
skipped 777
skipped 393
skipped 269
2020-04-05_11:08:34.565984 <gsmtrx:MILD> Transmit underrun by 13 timeslots [0x7fbf4c01b8f0]

The second try was with srsLTE. It's compile good for bladerf2 but I can't view any new station, just once time I could find a new station, don't know why because srslte do no print any errors.

Thinking in calibration I have tried to re-calibrate my new bladerf

I go to but 'Could not find serial number'

First try, the official documentation: ... Correction Meh, it's only for bladerf 1

bladeRF> cal lms

Error: Command requires FPGA to be loaded

bladeRF> info

Board: Nuand bladeRF 2.0 (bladerf2)
Serial #: xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
VCTCXO DAC calibration: 0x1d41
FPGA size: 49 KLE
FPGA loaded: yes
Flash size: 32 Mbit
USB bus: 4
USB address: 21
USB speed: SuperSpeed
Backend: libusb
Instance: 0

Ok, lets try with Kalibrate, I knew it because I have tried with Hackrf, Meh ! only for bladerf1

Ok, another idea: Using LTE-CELL-Scanner as source for calibration, Meh ! only for bladerf1

I do not doubt that bladerf2 it's better than 1, but with a lot of cool software that doesn't work in bladerf 2, for me, bladerf 1 its more attractive
Posts: 1
Joined: Fri Oct 28, 2022 7:49 pm

Re: beginning with bladerf 2 (errors and lot of unsupported software)

Post by ricudis »

I have succesfully ran LTE-Cell-Scanner with my BladeRF2 a4, by just commenting out the calls to


as they're used for display purposes only anyways.

LTE-Cell-Scanner gives me consistent frequency offsets and correction factors when I run it with the frequency range of band 7:

Detected the following cells:
DPX:TDD/FDD; A: #antenna ports C: CP type ; P: PHICH duration ; PR: PHICH resource type
DPX CID A fc freq-offset RXPWR C nRB P PR CrystalCorrectionFactor
FDD xx 4 2630M 27.8k -7.97 N 100 N 1/6 1.0000105664806848704
FDD xx 4 2630.1M -72.2k -15.2 N 100 N 1/6 0.99997254817689329442
FDD xx 2 2650M 28k -13.9 N 100 N one 1.0000105829472112351
FDD xx 2 2650M 28k -17.7 N 100 N one 1.0000105842637305731
FDD xx 2 2670M 28.3k -12.4 N 100 N one 1.0000106125007168778

Now I just don't know how to translate the frequency offset and CrystalCorrectionFactor to something usable for calibration.
Post Reply