BladeRF 2.0 micro xA4 unstability when sample rate changing

Having issues with the site, hardware, source code, or any other issues?
Post Reply
nitinjain
Posts: 2
Joined: Tue Nov 28, 2023 6:24 am

BladeRF 2.0 micro xA4 unstability when sample rate changing

Post by nitinjain »

Please refer to

https://github.com/Nuand/bladeRF/issues/955

and older issue related to same problem.

https://github.com/Nuand/bladeRF/issues/778

Setup:

bladeRF-cli version: 1.8.0-git-unknown
libbladeRF version: 2.4.1-git-unknown

Firmware version: 2.4.0-git-a3d5c55f
FPGA version: 0.14.0 (configured by USB host)

srsRAN_4G is latest (23.04 or 23.11)

When sample rate is changed on the fly (even if it is changed to same value), bladeRF 2.0 micro xa4 becomes unstable and gives out errors like:

command used from srsRAN_4G repo: ./lib/src/radio/test/benchmark_radio -s 11.52e6 -f 801.3e6 -t 10 -x -y

or ./lib/src/radio/test/benchmark_radio -s 1.92e6 -f 801.3e6 -t 10 -x -y

srsRAN_4G/lib/src/phy/rf/rf_soapy_imp.c:1004: Couldn't write all samples after 100 trials.
TTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

or

host/libraries/libbladeRF/src/streaming/sync.c:336] wait_for_buffer: Timed out waiting for buf_ready after 400 ms


Due to above issue, srsRAN_4G has highly intermittent behaviour in completing network attach when srsUE and srsenb used.
weightloom
Posts: 1
Joined: Fri Dec 29, 2023 3:50 am

Re: BladeRF 2.0 micro xA4 unstability when sample rate changing

Post by weightloom »

i'm having the same problem.
failrecover
Posts: 1
Joined: Tue Jan 16, 2024 9:37 pm

Re: BladeRF 2.0 micro xA4 unstability when sample rate changing

Post by failrecover »

Okay, managed to solve this by manual uploading of the FPGA from python and not installing the auto FPGA loader.
nitinjain
Posts: 2
Joined: Tue Nov 28, 2023 6:24 am

Re: BladeRF 2.0 micro xA4 unstability when sample rate changing

Post by nitinjain »

Hi @failrecover,
That is a great news. Can you please share exact steps for python uploading. I don't think I have done anything like that.
I sort of bypassed the issue by having a work around in different way when using bladeRF for srsRAN_4G codebase.
Please check below link:

https://github.com/srsran/srsRAN_4G/issues/1247

But what you have done is general solution.
That would be a great help for all of us.
Regards and Cheers!!
Nitin
Post Reply