Questions from a beginner

Discussions related to embedded firmware, driver, and user mode application software development

Moderator: robert.ghilduta

jom
Posts: 22
Joined: Tue Jul 19, 2016 10:08 pm

Re: Questions from a beginner

Post by jom » Sun Sep 18, 2016 10:54 pm

Hello yet again...just a question about the MATLAB "thunk" .dll file: I'm still having difficulty figuring this stuff out so I'll just ask:

What is the purpose again of the libbladeRF_thunk_pcwin64.dll file? You already have the bladeRF.dll so why the extra library file?

Thanks

jom

YenPang
Posts: 3
Joined: Wed Mar 21, 2018 7:59 am

Re: Questions from a beginner

Post by YenPang » Wed Mar 21, 2018 8:34 am

jom wrote:
Wed Aug 03, 2016 10:55 am
I moved the "libusb-1.0.20", "pthreads-w32" and "bladeRF" to the default locations. The "bladeRF" does not have a "lib" folder after I installed it in the default location but I don't know why CMake is looking for it.

As noted in the output CMake could not load "D:/Program Files/PothosSDR/lib/libusb-1.0.dll". The file is there so I don't know why it couldn't load. Does this relate to the "libusb-1.0.20" it is using in the other path? In fact, I don't even know how CMake knows Pothos was placed on my "D" drive. :?:

FX3_SDK_PATH is blank and I don't know what to put there anyway.

Before I ran this above I deleted the cache and deleted what was in the "build" directory.
Hi Jom,

I am a new beginner encountering almost the same problems you got before.

I also followed the same process listed on the github wiki page and I got stuck in the configuration of Cmake.

Cmake looked for the lib folder of the bladeRF directory and Cmake also couldn't find the pkgconfigure.

FX3_SDK_PATH is blank as you got before.

Could you let me know how you solve these problems?

Thank you very much.

YenPang

User avatar
rtucker
Posts: 59
Joined: Sun Jan 25, 2015 10:38 am

Re: Questions from a beginner

Post by rtucker » Wed Mar 21, 2018 1:15 pm

Greetings...

It is okay for FX3_SDK_PATH to be blank, as that is only needed if you're building without libusb. Also, there is no Windows equivalent to PkgConfigure, so that warning is normal.

Make sure that:
  • LIBPTHREADSWIN32_PATH is pointed at the pthreads-win32/pthreads.2 directory, where you've built the modified pthreads-win32
  • LIBUSB_PATH is pointed at the libusb-1.0.21 directory
  • ENABLE_BACKEND_LIBUSB is selected
  • ENABLE_BACKEND_CYAPI is NOT selected
Then hit "Configure" and it should be okay (with some red values); hit "Configure" again and it should be all okay with no red values.

If this doesn't work, let us know what errors you're getting and include a screenshot of the CMake window, and I'll take a look.
Rey Tucker (she/her)
Systems Engineer, Nuand LLC
Rochester, NY, USA

YenPang
Posts: 3
Joined: Wed Mar 21, 2018 7:59 am

Re: Questions from a beginner

Post by YenPang » Wed Mar 21, 2018 6:57 pm

Hi Rey,

Thank you for your reply.

I did the configuration again by following your suggestion.
When I did the first configuration, it shows the result as below.
CMake config1.PNG
It didn't show "LIBPTHREADSWIN32_PATH" until I checked the value of "ENABLE_BACKEND_LIBUSB". And the result of the second configuration is like the photo below.
CMake config2.PNG
And I continued pressing configure and got the results of the third one.
CMake config3.PNG
The configuration contained errors which makes me not be able to generate the executable file.

I installed "bladeRF Windows" and placed libusb-1.0.20 and pthreads-win32 at C:/Program Files (x86)/.
Is it because of the difference with libusb-1.0.20 and libusb-1.0.21?
What should I modify the pthreads-win32? I only modified the pthread.h by adding #define HAVE_STRUCT_TIMESPEC and #define PTW32_ARCHx64 near the top (I didn't see the include guard in it).
Is this the reason causing me stop?

Thank you again for your help.

YenPang

User avatar
rtucker
Posts: 59
Joined: Sun Jan 25, 2015 10:38 am

Re: Questions from a beginner

Post by rtucker » Thu Mar 22, 2018 8:37 am

When you say you installed "bladeRF Windows", do you mean you downloaded and installed a bladeRF-win-installer-*.exe file (available from http://nuand.com/installers.php)? If so, then that's all you need to do -- you don't need to install libusb or pthreads-win32, or compile libbladeRF, as it's already done. (I'm updating the Wiki page to clarify this.)

If you do need to build libbladeRF, then:

What is in the C:\Program Files (x86)\libusb-1.0.20\ and C:\Program Files (x86)\pthreads-win32\ directories?

Here's my CMake window, as well as the contents of my LIBUSB_PATH and LIBPTHREADSWIN32_PATH directories:
Screenshot_win10-1802eval_2018-03-22_00.png
Screenshot_win10-1802eval_2018-03-22_01.png
Rey Tucker (she/her)
Systems Engineer, Nuand LLC
Rochester, NY, USA

YenPang
Posts: 3
Joined: Wed Mar 21, 2018 7:59 am

Re: Questions from a beginner

Post by YenPang » Thu Mar 22, 2018 11:01 am

Hi Rey,

Yes, I just found that once I installed "bladeRF-win-installer-*.exe", I don't have to install others.

Anyway, thank you for your help.

YenPang

Post Reply