BladeRF with SDRSharp, driver issue?

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
Posts: 21
Joined: Sat Sep 08, 2018 2:05 pm

BladeRF with SDRSharp, driver issue?

Post by nipunamr » Sat Sep 08, 2018 2:11 pm

I have been trying to BladeRF x115 work with SDRSharp without any luck. I tried with both a windows7 and a windows 10 machine but couldn't get it to work. I followed the following video but couldn't get it to work.

I also used the guide from jmichep at github site as well and copied all the dlls to the main SDRSharp directory

I can't seem to get the BladeRF to show up in the drop down menu. I have noticed when I run BladRF-Cli program it crashes the first time and second time it works. when I do a "version" command I get the following,

BladeRF-cli version: 1.6.0
libbladeRF version: 2.0.0

Firmware version: 2.0.0
FPGA version: 0.7.3

when I go to zadig I see that following driver is installed

WinUSB (v6.1.7600.16385)

USB ID 2CF0 5246

I did update the FrontEnds.xml with bladeRF xml line.

Anyways when I do a bladeRF-cli -i -v verbose in cmd, I get the following,

C:\Users\Administrator>bladeRF-cli -i -v verbose
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/libusb.c:600] Using libusbversion:
[VERBOSE @ host/libraries/libbladeRF/src/backend/usb/libusb.c:477] Found a bladeRF (idx=1)
[WARNING @ host/libraries/libbladeRF/src/backend/usb/libusb.c:488] Found a blade
RF via VID/PID, but could not open it due to insufficient permissions.
[DEBUG @ host/libraries/libbladeRF/src/backend/usb/libusb.c:609] No devices available on the libusb backend.

No bladeRF device(s) available.

If one is attached, ensure it is not in use by another program
and that the current user has permission to access it.

It seems there's a permission issue, is that true? Any ideas on how to fix it?

I appreciate your help

Post Reply