BladeRF 2.0 xA9 -GRC 2 channel Rx

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
darkmess
Posts: 3
Joined: Sat Nov 24, 2018 7:20 am

BladeRF 2.0 xA9 -GRC 2 channel Rx

Post by darkmess » Sat Nov 24, 2018 7:30 am

Hi Nuand,

We have just purchased a xA9 to make use of the 2x Receive functionality. I have it working in single channel receive mode in GRC, but can't find any documentation on how I might configure the Osmocom driver to use both receive channels. The initial intention is just to record some short coherent snapshots from 2 antenna that will be post processed later.

Any help would be gratefully accepted.

robert.ghilduta
Posts: 50
Joined: Thu Feb 28, 2013 11:14 pm

Re: BladeRF 2.0 xA9 -GRC 2 channel Rx

Post by robert.ghilduta » Wed Dec 19, 2018 12:03 am

Sorry about the delayed response. Have you tried specifying the number of channels for the gr-osmo sink block to 2? You may have to set the block's device arguments (by double clicking the block) to "bladerf=0,nchan=2"
Yes, "bladeRF-cli -i" can be used to receive MIMO streams. Please try "rx config file=mimo.csv format=csv n=32768 channel=1,2".

darkmess
Posts: 3
Joined: Sat Nov 24, 2018 7:20 am

Re: BladeRF 2.0 xA9 -GRC 2 channel Rx

Post by darkmess » Mon Jan 07, 2019 4:21 am

Many thanks. setting the block arguments to "bladerf=0,nchan=2" worked perfectly.

darkmess
Posts: 3
Joined: Sat Nov 24, 2018 7:20 am

Re: BladeRF 2.0 xA9 -GRC 2 channel Rx

Post by darkmess » Thu Jan 10, 2019 3:54 am

Robert,

It seems that the gain control settings are not working properly from Osmocom in GRC also.

I have discovered a workaround by setting the block device arguments as so...

bladerf=0,
nchan=2, %enable dual Rx
agc_mode='manual' %set agc mode to manual-gain is set via rf_gain (i presume 'fast', 'slow', 'hybrid' will work also)

Post Reply