BladeRF 2.0 openLTE, srsLTE and YateBTS Problem

Discussions related to embedded firmware, driver, and user mode application software development

Moderator: robert.ghilduta

robert.ghilduta
Posts: 50
Joined: Thu Feb 28, 2013 11:14 pm

Re: BladeRF 2.0 openLTE, srsLTE and YateBTS Problem

Post by robert.ghilduta » Thu Dec 06, 2018 8:21 pm

Hello,

Sorry about the delay getting to this thread. Earlier, we wanted to get out a stable release by early Decemember after a mid Novemember pre-stable release. Unfortunately due to the fires in California and the subsequent holiday, the part of our small team that lives in California had their operations disrupted. We hope to release a pre-stable release by the end of this year, and a stable release in Q1 in conjunction with the Yate developers. So currently, our most recent branch of YateBTS that works with the bladeRF 2.0 micro is an older WIP that can be found here: https://nuand.com/downloads/yate.tar . Please note that both yate and yatebts have to be compiled (per instructions included), and installed, normal installation instructions apply otherwise. The only caveat is that you need to have your appropriate .RBF in ~/.config/Nuand/bladeRF directory.

Please note that due to the many years of development and testing the bladeRF 1.0 has enjoyed, the bladeRF 1.0 is a strong fit for YateBTS. If you are not happy with the current YateBTS and bladeRF 2.0, please contact me. If anyone needs prompt support or has any questions regarding these tools and programs feel free to give us a call, email, or contact us via our online inquiry.

We are working hard internally and with the YateBTS developers to enable the bladeRF 2.0 micro's superior hardware and capabilities to far exceed those of the bladeRF 1.0.

Lastly, please note that we do not own or make the YateBTS development schedule. Our codebase is something we have created and maintain, so please direct questions about it solely to us to spare the Yate developers for the time being.

Also, there has been several questions regarding OpenAirInterface. OAI has not moved their libbladeRF 2.0 branch over to master yet. The code for libbladeRF (and thus micro support) is available on the gitlab "develop" branch: https://gitlab.eurecom.fr/oai/openairin ... ee/develop

SRS-LTE upgraded to the libbladeRF 2.0, so the bladeRF micro can be used with the lastest master branch from https://github.com/srsLTE/srsLTE .

Post Reply