How to validate that BladeRF is transmitting

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
cdh055
Posts: 1
Joined: Tue Jan 22, 2019 12:43 pm

How to validate that BladeRF is transmitting

Post by cdh055 » Tue Jan 22, 2019 12:49 pm

Hello,

I am attempting to run srsLTE UE on the bladeRFx115 board I have.

I am attempting to attach the UE to an LTE picocell

All of the debug messages on both sides imply that the bladeRF is properly decoding the eNB control channel, it receives the SIBs and then it trys to transmit a RACH request.

The Picocell never sees the transmit from the BladeRF.

I am powering the BladeRF with USB3.0 power. Is that acceptable? Or do I need a separate power supply?

Is there a way to easily verify that the board can transmit properly?

Thanks,

Dave

OskarM
Posts: 17
Joined: Sun Dec 09, 2018 3:02 pm

Re: How to validate that BladeRF is transmitting

Post by OskarM » Tue Feb 12, 2019 1:09 pm

Dave,
I found it quite useful to have rtl-sdr and few dB of attenuators at hand. This way you can easily check if there is any output on the bladeRF. Additionally - if you'd had a splitter or such - you could potentially monitor TX output live.

Has the bladeRF enough output power to talk to LTE pico cell? The CW output is said to be +6dBm, but for wideband signal it will get definitely lower and will get more noise. So it may be actually responding but the signal cannot reach the tower.

b.r.

Post Reply