Updating from libbladeRF 2.2.0 to 2.2.1: PPA Won't Die!

Discussions related to embedded firmware, driver, and user mode application software development

Moderator: robert.ghilduta

Post Reply
DavidGW
Posts: 3
Joined: Thu Oct 03, 2019 6:23 pm

Updating from libbladeRF 2.2.0 to 2.2.1: PPA Won't Die!

Post by DavidGW » Thu May 07, 2020 7:29 pm

Hello All,

Running Ubuntu on Jetson TX2 and Nano. I am writing a C++ script to control a BladeRF 2.0 xA4.

I'm currently having a situation where I'm opening the BladeRF, trying to do something (like a scheduled RX) but then it fails due to an 'in the past' error. Sometimes I get this error every RX, sometimes I don't get it at all. It appears deinitialising and reinitialising the BladeRF can switch it from a functional to nonfunctional state, or vice versa. This appears to be happening because at a reasonably low level the timer thinks it is a very high number. I've got this from looking at debug messages, where it looks like it's failing due to a specific "t=1311747200790054173" bug. This has apparently been fixed in a later libbladerf release.

I have previously installed libbladerf using the Ubuntu PPA method, which installed bladeRF-cli version 1.7.1, and libbladerf version 2.2.0. I am now trying to upgrade to the newest versions, which appear to be bladeRF-cli 1.8.0, and libbladerf 2.2.1. I have therefore followed the instructions in the Getting Started section for building BladeRF libraries from GitHub source (git clone the directory, configure with cmake then build with make). Now, running "bladeRF-cli -e version" shows my bladeRF-cli has been updated to 1.8.0, however libbladerf is still 2.2.0 rc3 ppabionic, instead of the 2.2.1 that was built from the GitHub repository. Also, running my C++ script still hits the timer bug.

It appears the PPA-installed 2.2.0 version persists, and I'm really struggling to kill it off so the bladeRF-cli and my C++ script start seeing the newer version.

Any ideas on killing a PPA? I've tried running "apt-get remove bladerf", basically the reverse steps to how I installed it, however that hasn't worked, code and the cli still find version 2.2.0 and run poorly.

Thanks for your help,

David

Post Reply